const regex = new RegExp('https?://\\S+\\K\\shttps?://\\S+', '')
const str = `https://t.co/DJFjdleJcI3 https://t.co/DJEm5ltcjZ`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);