$re = '~https?://\S+\K\shttps?://\S+~';
$str = 'https://t.co/DJFjdleJcI3 https://t.co/DJEm5ltcjZ';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;