import re
regex = re.compile(r"https?://\S+\K\shttps?://\S+")
test_str = "https://t.co/DJFjdleJcI3 https://t.co/DJEm5ltcjZ"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)