#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "cow(.^[a-zA-Z]*)milk"
Local $sString = "cow milk" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)