import re
regex = re.compile(r"cow(.^[a-zA-Z]*)milk")
test_str = ("cow milk\n\n")
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)