const regex = /cow(.^[a-zA-Z]*)milk/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cow(.^[a-zA-Z]*)milk', 'g')
const str = `cow milk
`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);