import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[0-9]{1,2}\\.[0-9]{1,4}\\b";
final String string = "I am trying to use regex to extract a certain syntax, in my case something like \"10.100\" or \"20.111\", in which 2 numbers are separated by dot(.) . So if I provide \"a 10.100\", it will extract 10.100 from the string. If I provide \"a 10.100 20.101\", it will extract 10.100 and 20.101.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}