re = /\b[0-9]{1,2}\.[0-9]{1,4}\b/
str = 'I am trying to use regex to extract a certain syntax, in my case something like "10.100" or "20.111", in which 2 numbers are separated by dot(.) . So if I provide "a 10.100", it will extract 10.100 from the string. If I provide "a 10.100 20.101", it will extract 10.100 and 20.101.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end