# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[0-9]{1,2}\.[0-9]{1,4}\b"
test_str = "I am trying to use regex to extract a certain syntax, in my case something like \"10.100\" or \"20.111\", in which 2 numbers are separated by dot(.) . So if I provide \"a 10.100\", it will extract 10.100 from the string. If I provide \"a 10.100 20.101\", it will extract 10.100 and 20.101."
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.