using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{.+\""from\"":\""(\d+)\"".+\""checkId\"":\""(\d+)\"".+\""keyword\"":\""([a-zA-Z]+)\"".+\}";
string input = @"{""transfId"":""S0722182156164591494745777M"",""messageId"":""123"",""from"":""5777"",""to"":""59395436474"",""status"":-1,""checkId"":""1975"",""price"":0,""keyword"":""OK"",""errorCode"":601,""errorMessage"":""SUCCESS"",""date"":""20150730 09:00:00"",""model"":""wer_tr""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}