// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\{.+\"from\":\"(\d+)\".+\"checkId\":\"(\d+)\".+\"keyword\":\"([a-zA-Z]+)\".+\}"#).unwrap();
let string = "{\"transfId\":\"S0722182156164591494745777M\",\"messageId\":\"123\",\"from\":\"5777\",\"to\":\"59395436474\",\"status\":-1,\"checkId\":\"1975\",\"price\":0,\"keyword\":\"OK\",\"errorCode\":601,\"errorMessage\":\"SUCCESS\",\"date\":\"20150730 09:00:00\",\"model\":\"wer_tr\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}