$re = '/\[(if)\s+([^\]]*+)\]
((?>[^[]++(?:\[(?!(?:end)?if\b)[^[]*)*|(?R))*)
\[endif\]/sx';
$str = '[if coooondition1] aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa [if condaition2] baab [endif] [endif]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);