import re
regex = re.compile(r"""
\[(if)\s+([^\]]*+)\]
((?>[^[]++(?:\[(?!(?:end)?if\b)[^[]*)*|(?R))*)
\[endif\]
""", flags=re.DOTALL | re.VERBOSE)
test_str = "[if coooondition1] aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa [if condaition2] baab [endif] [endif]"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")