#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?<!#)(\w+)\s(\w+)\s(\[.*?\])\s/(.+)/$"
Local $sString = "# For more information about CC-CEDICT see:" & @CRLF & _
"# http://cc-cedict.org/wiki/" & @CRLF & _
"A A [A] /(slang) (Tw) to steal/" & @CRLF & _
"AA制 AA制 [A A zhi4] /to split the bill/to go Dutch/" & @CRLF & _
"AB制 AB制 [A B zhi4] /to split the bill (where the male counterpart foots the larger portion of the sum)/(theater) a system where two actors take turns in acting the main role, with one actor replacing the other if either is unavailable/" & @CRLF & _
"A咖 A咖 [A ka1] /class "A"/top grade/" & @CRLF & _
"A圈兒 A圈儿 [A quan1 r5] /at symbol, @/" & @CRLF & _
"A片 A片 [A pian4] /adult movie/pornography/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")