import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<!#)(\\w+)\\s(\\w+)\\s(\\[.*?\\])\\s/(.+)/$";
final String string = "# For more information about CC-CEDICT see:\n"
+ "# http://cc-cedict.org/wiki/\n"
+ "A A [A] /(slang) (Tw) to steal/\n"
+ "AA制 AA制 [A A zhi4] /to split the bill/to go Dutch/\n"
+ "AB制 AB制 [A B zhi4] /to split the bill (where the male counterpart foots the larger portion of the sum)/(theater) a system where two actors take turns in acting the main role, with one actor replacing the other if either is unavailable/\n"
+ "A咖 A咖 [A ka1] /class \"A\"/top grade/\n"
+ "A圈兒 A圈儿 [A quan1 r5] /at symbol, @/\n"
+ "A片 A片 [A pian4] /adult movie/pornography/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}