# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<!#)(\w+)\s(\w+)\s(\[.*?\])\s/(.+)/$"
test_str = ("# For more information about CC-CEDICT see:\n"
"# http://cc-cedict.org/wiki/\n"
"A A [A] /(slang) (Tw) to steal/\n"
"AA制 AA制 [A A zhi4] /to split the bill/to go Dutch/\n"
"AB制 AB制 [A B zhi4] /to split the bill (where the male counterpart foots the larger portion of the sum)/(theater) a system where two actors take turns in acting the main role, with one actor replacing the other if either is unavailable/\n"
"A咖 A咖 [A ka1] /class \"A\"/top grade/\n"
"A圈兒 A圈儿 [A quan1 r5] /at symbol, @/\n"
"A片 A片 [A pian4] /adult movie/pornography/")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.