import re
regex = re.compile(r"(?i)<img[^>]+? src\s*?=\s*?\"(.*?\?contextId.*?)\"[^\/]+?\/>", flags=re.MULTILINE)
test_str = ("<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier\" alt=\"Bild Übersicht Router\" title=\"Übersicht Router\" />\n\n"
"<p> sdfs </p>\n\n"
"<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://localhost:8080/resource/carl/eService/rain/apple.png?contextId=eservice_aaa\" alt=\"Communicator\" title=\"Super Robot\" />\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")