// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)<img[^>]+? src\s*?=\s*?"(.*?\?contextId.*?)"[^\/]+?\/>"#).unwrap();
let string = "<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier\" alt=\"Bild Übersicht Router\" title=\"Übersicht Router\" />
<p> sdfs </p>
<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://localhost:8080/resource/carl/eService/rain/apple.png?contextId=eservice_aaa\" alt=\"Communicator\" title=\"Super Robot\" />
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}