use strict;
my $str = 'background-color:#000000; background-image:url(https://www.sample.com/free-videos/player-images/20170204-01.jpg); background-size: cover; position: relative;';
my $regex = qr`.*?(https?:\/\/\S*\.jpg).*`mp;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";