re = /.*?(https?:\/\/\S*\.jpg).*/m
str = 'background-color:#000000; background-image:url(https://www.sample.com/free-videos/player-images/20170204-01.jpg); background-size: cover; position: relative;'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result