package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\$\[([(a-z-A-Z.)]*)]`)
var str = `<p>I have $$[worksAmount] works and $$[reviewsAmount] reviews</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}