re = /\$\$\[([(a-z-A-Z.)]*)]/m
str = '<p>I have $$[worksAmount] works and $$[reviewsAmount] reviews</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end