$re = '/\$\$\[([(a-z-A-Z.)]*)]/m';
$str = '<p>I have $$[worksAmount] works and $$[reviewsAmount] reviews</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);