package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)image(\d\d)$`)
var str = `image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105`
var substitution = "image0$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}