using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((?=\w{20,}))(\s?(?:\w+\s){0,2}\w*))";
string input = @"UltralongcharacterthatistoolongThese are up to three words.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}