$re = '/(((?=\w{20,}))(\s?(?:\w+\s){0,2}\w*))/';
$str = 'UltralongcharacterthatistoolongThese are up to three words.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);