const regex = /(((?=\w{20,}))(\s?(?:\w+\s){0,2}\w*))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((?=\\w{20,}))(\\s?(?:\\w+\\s){0,2}\\w*))', '')
const str = `UltralongcharacterthatistoolongThese are up to three words.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}