using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\h*(['""])(.+?)\h*(?!\\)(?=\1)";
string input = @"""Backbone.Radio( 'comments ').trigger(""added:comment "" ,function(){});""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}