re = /\(\h*(['"])(.+?)\h*(?!\\)(?=\1)/
str = '"Backbone.Radio( \'comments \').trigger("added:comment " ,function(){});"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end