$re = '~\(\h*([\'"])(.+?)\h*(?!\\\\)(?=\1)~';
$str = '"Backbone.Radio( \'comments \').trigger("added:comment " ,function(){});"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);