using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\B('|"")[^\""']*),(?![^\""']*('|"")\B)";
string input = @"""\""search\"", placeholder: \""Busca rápida: 1.4 8V, Flex, automático...\"", id: \""#search_terms\"" """;
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}