$re = '/(?!\B(\'|")[^\"\']*),(?![^\"\']*(\'|")\B)/';
$str = '"\\"search\\", placeholder: \\"Busca rápida: 1.4 8V, Flex, automático...\\", id: \\"#search_terms\\" "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);