re = /(?!\B('|")[^\"']*),(?![^\"']*('|")\B)/
str = '"\\"search\\", placeholder: \\"Busca rápida: 1.4 8V, Flex, automático...\\", id: \\"#search_terms\\" "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end