package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?(love|like).*(programming)`)
var str = `I love love programming love a lot! love`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}