$re = '/.*?(love|like).*(programming)/';
$str = 'I love love programming love a lot! love';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);