const regex = /.*?(love|like).*(programming)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(love|like).*(programming)', '')
const str = `I love love programming love a lot! love`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}