package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:\+27|27)|0)(\d{9})$`)
var str = `08277 11380`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}