$re = '/^((?:\+27|27)|0)(\d{9})$/';
$str = '08277 11380';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);