#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)\s*(?::)(\s*_\s*\|\s*\w+\s*:\s*-\w+\.\|)"
Local $sString = "test1:_|TEST:-TEST.|" & @CRLF & _
"test2:_|TEST:-TEST.|" & @CRLF & _
"test3:_|TEST:-TEST.|"
Local $sSubst = "$1;$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)