re = /(\w+)\s*(?::)(\s*_\s*\|\s*\w+\s*:\s*-\w+\.\|)/m
str = 'test1:_|TEST:-TEST.|
test2:_|TEST:-TEST.|
test3:_|TEST:-TEST.|'
subst = '$1;$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result