use strict;
my $str = 'test1:_|TEST:-TEST.|
test2:_|TEST:-TEST.|
test3:_|TEST:-TEST.|';
my $regex = qr/(\w+)\s*(?::)(\s*_\s*\|\s*\w+\s*:\s*-\w+\.\|)/mp;
my $subst = '$1;$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";