package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}`)
var str = `{[]()}
{[word]( word2 )}`
var substitution = "{[a]$1b$2(c)$3)}"
fmt.Println(re.ReplaceAllString(str, substitution))
}