use strict;
my $str = '{[]()}
{[word]( word2 )}';
my $regex = qr/{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}/p;
my $subst = '{[a]$1b$2(c)$3)}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";