const regex = /{\s*\[(\w*)\]\s*(\w*)\s*\(([\w\s]*)\)\s*}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{\\s*\\[(\\w*)\\]\\s*(\\w*)\\s*\\(([\\w\\s]*)\\)\\s*}', 'g')
const str = `{[]()}
{[word]( word2 )}`;
const subst = `{[a]$1b$2(c)$3)}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);