import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<string>'[^']++')\n"
+ " (?<int>\\b\\d+\\b)\n"
+ " (?<sp>\\s*)\n"
+ " (?<key>\\b\\w+\\b)\n"
+ " (?<value>(?&string)|(?&int))\n"
+ " (?<exp>(?&key) (?&sp) = (?&sp) (?&value))\n"
+ " (?<logic>\\b (?:and|or) \\b)\n"
+ " (?<main>\n"
+ " (?<token> \\( (?&sp) (?&main) (?&sp) \\) | (?&exp) )\n"
+ " (?:\n"
+ " (?&sp) (?&logic) (?&sp)\n"
+ " (?&token) \n"
+ " )*\n"
+ " )\n"
+ ")\n"
+ "(?:\n"
+ " ^ (?&sp) (?= (?&main) (?&sp) $ )\n"
+ " |\n"
+ " (?!^) \\G\n"
+ " (?&sp) (?&logic) (?&sp)\n"
+ ")\n"
+ "(?:\n"
+ " \\( (?&sp) (?<m_main>(?&main)) (?&sp) \\)\n"
+ " |\n"
+ " (?<m_key>(?&key)) (?&sp) = (?&sp) (?<m_value>(?&value))\n"
+ ")";
final String string = "name = 'benjo' and (surname = 'benny' or surname = 'bennie') or age = 4\n"
+ "or \n"
+ "name = 'benjo' and (surname = 'benny' or surname = 'bennie') or (age = 4 or age = 6)\n"
+ "and\n"
+ "(name = 'benjo' or name='xxx') and (surname = 'benny' or surname = 'bennie') or age = 4";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}