const regex = /(?(DEFINE)
(?<string>'[^']++')
(?<int>\b\d+\b)
(?<sp>\s*)
(?<key>\b\w+\b)
(?<value>(?&string)|(?&int))
(?<exp>(?&key) (?&sp) = (?&sp) (?&value))
(?<logic>\b (?:and|or) \b)
(?<main>
(?<token> \( (?&sp) (?&main) (?&sp) \) | (?&exp) )
(?:
(?&sp) (?&logic) (?&sp)
(?&token)
)*
)
)
(?:
^ (?&sp) (?= (?&main) (?&sp) $ )
|
(?!^) \G
(?&sp) (?&logic) (?&sp)
)
(?:
\( (?&sp) (?<m_main>(?&main)) (?&sp) \)
|
(?<m_key>(?&key)) (?&sp) = (?&sp) (?<m_value>(?&value))
)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<string>\'[^\']++\')
(?<int>\\b\\d+\\b)
(?<sp>\\s*)
(?<key>\\b\\w+\\b)
(?<value>(?&string)|(?&int))
(?<exp>(?&key) (?&sp) = (?&sp) (?&value))
(?<logic>\\b (?:and|or) \\b)
(?<main>
(?<token> \\( (?&sp) (?&main) (?&sp) \\) | (?&exp) )
(?:
(?&sp) (?&logic) (?&sp)
(?&token)
)*
)
)
(?:
^ (?&sp) (?= (?&main) (?&sp) $ )
|
(?!^) \\G
(?&sp) (?&logic) (?&sp)
)
(?:
\\( (?&sp) (?<m_main>(?&main)) (?&sp) \\)
|
(?<m_key>(?&key)) (?&sp) = (?&sp) (?<m_value>(?&value))
)', 'g')
const str = `name = 'benjo' and (surname = 'benny' or surname = 'bennie') or age = 4
or
name = 'benjo' and (surname = 'benny' or surname = 'bennie') or (age = 4 or age = 6)
and
(name = 'benjo' or name='xxx') and (surname = 'benny' or surname = 'bennie') or age = 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}