$re = '/(?(DEFINE)
(?<string>\'[^\']++\')
(?<int>\b\d+\b)
(?<sp>\s*)
(?<key>\b\w+\b)
(?<value>(?&string)|(?&int))
(?<exp>(?&key) (?&sp) = (?&sp) (?&value))
(?<logic>\b (?:and|or) \b)
(?<main>
(?<token> \( (?&sp) (?&main) (?&sp) \) | (?&exp) )
(?:
(?&sp) (?&logic) (?&sp)
(?&token)
)*
)
)
(?:
^ (?&sp) (?= (?&main) (?&sp) $ )
|
(?!^) \G
(?&sp) (?&logic) (?&sp)
)
(?:
\( (?&sp) (?<m_main>(?&main)) (?&sp) \)
|
(?<m_key>(?&key)) (?&sp) = (?&sp) (?<m_value>(?&value))
)/x';
$str = 'name = \'benjo\' and (surname = \'benny\' or surname = \'bennie\') or age = 4
or
name = \'benjo\' and (surname = \'benny\' or surname = \'bennie\') or (age = 4 or age = 6)
and
(name = \'benjo\' or name=\'xxx\') and (surname = \'benny\' or surname = \'bennie\') or age = 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);