package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:((?:.+?)(?: of the )?)+) of the (?:(.+?)) (?:"(.+?)")$`)
var str = `'age of the person "Bob"'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}