const regex = /^(?:((?:.+?)(?: of the )?)+) of the (?:(.+?)) (?:"(.+?)")$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:((?:.+?)(?: of the )?)+) of the (?:(.+?)) (?:"(.+?)")$', '')
const str = `'age of the person "Bob"'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}