re = /^(?:((?:.+?)(?: of the )?)+) of the (?:(.+?)) (?:"(.+?)")$/
str = '\'age of the person "Bob"\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end